Puzzle ITC - Power Outage at Belpstrasse – Incident details

Power Outage at Belpstrasse

Resolved
Operational
Started 4 months agoLasted about 1 hour

Affected

Office

Operational from 4:07 PM to 5:15 PM

Network Office-Bern

Operational from 4:07 PM to 5:15 PM

Google Meet Hardware

Operational from 4:07 PM to 5:15 PM

Telephone Setup

Operational from 4:07 PM to 5:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating this incident. VPN access is not working at the moment