Puzzle ITC - Youtrack Down – Incident details

Youtrack Down

Resolved
Operational
Started 11 months agoLasted 8 minutes

Affected

Puzzle Services

Operational from 11:41 AM to 11:49 AM

Youtrack

Operational from 11:41 AM to 11:49 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating
    We are currently investigating this incident.