Puzzle ITC - Youtrack Down – Incident details

Youtrack Down

Resolved
Operational
Started 11 months agoLasted 25 minutes

Affected

Puzzle Services

Operational from 3:23 PM to 3:48 PM

Youtrack

Operational from 3:23 PM to 3:48 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    We are currently investigating this incident.