Puzzle ITC - Performance Drop in Backlogs since OpenProject 17.2.2 – Incident details

Performance Drop in Backlogs since OpenProject 17.2.2

Resolved
Major outage
Started about 1 month agoLasted 29 days

Affected

Puzzle Services

Degraded performance from 7:00 PM to 8:50 AM

Project Management

Degraded performance from 7:00 PM to 8:50 AM

OpenProject

Degraded performance from 7:00 PM to 8:50 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved with update 17.3.

  • Monitoring
    Monitoring

    OpenProject is actively working on a bug fix for the issue we’ve been experiencing. Progress has been made, and we can expect a patch in the near future.

    If you are experiencing performance issues with OpenProject due to large backlogs, we recommend using "Arbeitspakete" (Work Packages) view and disabling the option "Show versions folded" to mitigate the issue.

  • Resolved
    Resolved

    We have observed a significant drop in performance in the Backlogs module after updating to OpenProject 17.2.2.
    The following issues are particularly noticeable:

    1. Slow loading times:

      • Initial loading of backlogs takes considerably longer than in previous versions.

      • Opening individual features/stories within the backlog is delayed (2–3 seconds per interaction).

    2. Undesired GUI behavior:

      • Certain interactions (e.g., drag-and-drop sorting) exhibit unexpected delays or visual glitches, even though the backlog content itself remains unaffected.

    Context:

    • The issues emerged after the 17.2.0 update, which introduced the Primer Design System and Turbo/StimulusJS for dynamic updates in the Backlogs module.

    • The problems are reproducible with large backlogs and persist in 17.2.2.

    Workaround:

    • Disabling "Show versions folded" in user settings mitigates the drag-and-drop issue, but is not a sustainable solution due to usability concerns.

    We are currently investigating potential solutions and will keep you updated on our progress.