Scheduled for 7. August 2025 at 14:45 – 15:48
Affects
Puzzle Services
Under maintenance from 2:45 PM to 3:48 PM
PuzzleTime
Under maintenance from 2:45 PM to 3:48 PM
Completed
7. August 2025 at 15:48Completed
7. August 2025 at 15:48PTime Maintenance has completed successfully.
Planned
7. August 2025 at 14:45Planned
7. August 2025 at 14:45We will deploy Hotfix 2.15.1, which includes a few bug fixes / improvements. You can find the associated Changelog in PuzzleTime at the top left by clicking on the version number after finishing the deployment. For questions or inputs please contact the Puzzle-Team at puzzle chat channel #puzzletime.
In progress
7. August 2025 at 14:42In progress
7. August 2025 at 14:42PTime Maintenance is now in progress.