Puzzle ITC - Printer BE37 not working – Incident details
Report an issue
Get updates
Email
Slack
Microsoft Teams
Google Chat
Webhook
RSS
Atom
API
Report an issue
Get updates
Dark mode
All systems operational
Printer BE37 not working
Resolved
Partial outage
Started 7 days ago
Lasted about 7 hours
Affected
Office
Operational from 7:50 AM to 3:01 PM
Network Office-Bern
Operational from 7:50 AM to 3:01 PM
Updates
Resolved
8. November 2024 at 15:1
Resolved
8. November 2024 at 15:1
This incident has been resolved.
Investigating
8. November 2024 at 7:50
Investigating
8. November 2024 at 7:50
We are currently investigating this incident.