Puzzle ITC - Google Meet – Incident details

Google Meet

Resolved
Operational
Started 12 months agoLasted 2 months

Affected

Office

Operational from 6:29 AM to 7:47 AM

Google Meet Hardware

Operational from 6:29 AM to 7:47 AM

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Our Google Meet conference setup in the Meeting room GNU is currently unstable and may not operate as designed. We are working on a solution to restore full functionality. Thank you for your patience, and we will keep you updated on our progress.