Completed
PuzzleTime Version 2.10

Status
Resolved after less than a minute
Started
17. November 2022 at 0:30
Completed
17. November 2022 at 0:30
Affects
PuzzleTime
  • Completed
    17. November 2022 at 0:30

    This maintenance has long been completed but we forgot to close the maintenance ;)