Cyptopus Release 4.1

Completed
Scheduled for 8. March 2022 at 6:30 – 6:36

Affected

Puzzle Services
Cryptopus
Updates
  • Completed
    8. March 2022 at 6:36
    Completed
    8. March 2022 at 6:36

    Maintenance has completed successfully.

  • Update
    8. March 2022 at 6:30
    In progress
    8. March 2022 at 6:30

    Maintenance is now in progress

  • In progress
    8. March 2022 at 6:30
    In progress
    8. March 2022 at 6:30

    We are planning Cryptopus Production Release 4.1.