Completed
Spamfilter Maintenance

Status
Resolved after about 2 hours
Started
22. December 2021 at 16:0
Completed
22. December 2021 at 18:20
Affects
Mail
  • Completed
    22. December 2021 at 18:20

    Maintenance has completed successfully.

  • Planned
    22. December 2021 at 16:0

    We are planning for a scheduled maintenance during that time. We do not expect any interruptions