Google Meet Hardware experiencing degraded performance

Resolved
sending and receiving mails is currently not possible

Started
17. December 2021 at 7:37
Status
Resolved after 35 minutes

Impact

Minor outage
Affected
Puzzle Services
Mail
  • Resolved
    Resolved

    We just resolved the issue!

  • Investigating
    Investigating

    We are currently investigating this incident.